Центральный Дом Знаний - Работа в 1С 16

Информационный центр "Центральный Дом Знаний"

Заказать учебную работу! Жми!



ЖМИ: ТУТ ТЫСЯЧИ КУРСОВЫХ РАБОТ ДЛЯ ТЕБЯ

      cendomzn@yandex.ru  

Наш опрос

Как Вы планируете отдохнуть летом?
Всего ответов: 903

Онлайн всего: 1
Гостей: 1
Пользователей: 0


Форма входа

Логин:
Пароль:

Работа в 1С 16

Работа в программе 1С

стр.: 1  2  3  4  5  6  7  8  9  10  11  12  13  14  15  16  17  18  19  20  21  22  23  24  25  26  27  28  29  30  31  32
33  34  35  36  37  38  39  40  41  42  43  44  45  

Пример:

Док.ВыбратьДокументы(ДатаНачала, ДатаОкончания);

// Цикл выбора документов

Пока Док.ПолучитьДокумент() > 0 Цикл

// присвоим переменной ТекДок значение найденного документа

ТекДок = Док.ТекущийДокумент();

КонецЦикла;

Выбрать(<Подсказка>, <ФормаЖурнала>, <КомуПодч>) – вызывает диалоговое окно для выбора документа и затем позиционирует выбранный документ в качестве текущего. Данный метод может использоваться только для объектов, созданных функцией СоздатьОбъект().

Параметры:

<Подсказка> – текст заголовка окна диалога ввода. Может использоваться в качестве подсказки конечному пользователю.

<ФормаЖурнала> – строковое выражение идентификатора той формы журнала документа (как он объявлен в конфигураторе), которая должна использоваться для выбора. Если это значение пустое, то используется форма журнала по умолчанию. Можно указывать имя объекта в следующем виде:·"Журнал.ХХХХХ", где ХХХХХ – имя вида соответствующего объекта, как он задан в конфигураторе, например: "Журнал.КадровыеДокументы".

<КомуПодч> – необязательный параметр. Используется при открытии выбора по журналу подчиненных документов, т. е. когда второй параметр <ФормаЖурнала> имеет значение "Журнал.Подчиненные". В данном случае в этом параметре передается документ–владелец, по которому следует построить журнал подчиненных документов.

Возвращаемое значение:

Числовое значение: 1 – если документ выбран; 0 – если не выбран.

ВидыДляВыбора(<СписокВидов>) – устанавливает выбираемые виды для объекта–документ неопределенного вида. Данный метод обычно используется до начала интерактивного позиционирования документа, например, при помощи метода Выбрать(). Данный метод может использоваться только для объектов типа Документ неопределенного вида – либо созданных функцией СоздатьОбъект(), либо определенных в конфигураторе как реквизиты диалога или другого объекта. Если метод ВидыДляВыбора() применен к реквизиту диалога типа Документ неопределенного вида, то интерактивный выбор будет производиться только среди установленных видов документов.

Параметры:

<СписокВидов> – необязательный параметр. Строковое выражение содержащее список видов выбираемых документов, разделенных запятыми.

Возвращаемое значение: строковое значение, содержащее текущий список видов выбираемых документов, разделенных запятыми (на момент до исполнения метода).

Пример:

// данная Процедура присваивает некоторому реквизиту "НаОсновании"

// значение конкретного документа

Процедура УстДокОснования()

// Создадим объект типа «документ» неопределенного вида

Дкм = СоздатьОбъект("Документ");

Дкм.ВидыДляВыбора("РасходнаяНакл, Счет");

// Вызываем диалог выбора документа

Если Дкм.Выбрать("Выберите документ основания", "") > 0 Тогда

НаОсновании = Дкм.ТекущийЭлемент();

КонецЕсли;

КонецПроцедуры

Итог(<ИмяРеквизита>) – позволяет определить сумму значений по всем строкам табличной части документа для реквизита <ИмяРеквизита>. Данный метод может быть использован только для реквизитов табличной части документов, для которых установлено свойство «Итог по колонке» (закладка «Дополнительные» свойств реквизита документа в конфигураторе).

Параметры:

<ИмяРеквизита> – строковое выражение, содержащее имя реквизита табличной части документа, для которого в конфигураторе установлено свойство «Итог по колонке».

Возвращаемое значение: сумма по всем строкам табличной части документа для реквизита <ИмяРеквизита>.

Пример:

Процедура ВычСреднего()

// вычислим среднюю сумму по наряду

Сумма = Итог("Сумма");

Штук = Итог("Штук");

Если Штук <> 0 Тогда

Средн = Сумма / Штук;

Иначе

Средн = 0;

КонецЕсли;

КонецПроцедуры

ПолучитьСтрокуПоНомеру(<Номер>) – устанавливает в качестве текущей строки спецификации документа строку с заданным номером (не порядковым, а тем, который записан в строке, т. к. могут быть пропуски).

Параметры:

<Номер>– выражение, содержащее номер искомой строки.

Возвращаемое значение: 1 – если действие выполнено; 0 – если действие не выполнено.

Пример:

Процедура УдалЗаданнойСтроки(Док, Стр)

Если Док.Выбран() = 1 Тогда

// Если переданный параметр содержит значение документа, то

// найдем в нем строку

Док.ПолучитьСтрокуПоНомеру(Стр);

// удалим найденную строку спецификации документа

Док.УдалитьСтроку();

Иначе

Предупреждение("Документ не выбран!");

КонецЕсли;

КонецПроцедуры;

ВыбратьПоЗначению(<НачалоВыборки>, <КонецВыборки>, <ИмяОтбора>, <3нач>) – открывает выборку документов в интервале с <НачалоВыборки> по <КонецВыборки>, для которых реквизит отбора <ИмяОтбора> имеет конкретное заданное значение <3нач>. Непосредственно сама выборка осуществляется при помощи метода ПолучитьДокумент() в порядке возрастания даты и времени записи документов (если не задан обратный порядок методом ОбратныйПорядок()). Данный метод может использоваться только для объектов, созданных функцией СоздатьОбъект().

Параметры:

<НачалоВыборки> – необязательный параметр. Выражение типа дата, документ или позиция документа, с которого устанавливается начало выборки документов. Если данный параметр опущен, то выборка начинается с самого первого существующего в системе документа.

<КонецВыборки> – необязательный параметр. Выражение типа дата, документ или позиция документа, на котором устанавливается конец выборки документов. Если данный параметр опущен, то выборка заканчивается самым последним существующим в системе документом.

<ИмяОтбора> – строковое выражение, которое содержит либо название «общего реквизита» документов, либо название «графы отбора» журналов, как они заданы в конфигураторе.

<3нач> – значение отбора, по которому строится выборка документов.

Возвращаемое значение: 1 – если действие выполнено и в выборке есть хотя бы один документ; 0 – если действие не выполнено или в выборке нет ни одного документа.

Пример:

Док = СоздатьОбъект("Документ");

// открываем выборку документов

Док.ВыбратьПоЗначению(ДатаНачало, ДатаКонец, "Автор", "Сидоров");

// цикл получения документов

Пока Док.ПолучитьДокумент() > 0 Цикл

ТекДок = Док.ТекущийДокумент();

КонецЦикла;

ВыбратьПоНомеру(<Номер>, <Дата>, <ИдентВида>) – открывает выборку всех документов с данным номером одного вида или одного нумератора (например, для поиска всех документов с совпадающими номерами). В качестве второго параметра задается любая дата из диапазона, в котором нужно искать документ с данным номером. Поиск зависит от выбранного в конфигураторе способа уникальности номеров (по месяцу, году и др.). Метод может быть использован для объекта Документ общего вида, тогда для поиска нужно указать в параметре <ИдентВида> идентификатор вида документа или идентификатор Нумератора. Непосредственно сама выборка осуществляется при помощи метода ПолучитьДокумент() в порядке возрастания даты и времени записи документов (если не задан обратный порядок методом ОбратныйПорядок()). Данный метод может использоваться только для объектов, созданных функцией СоздатьОбъект().

Параметры:

<Номер> – строковое выражение, содержащее значение номера искомых документов.

<Дата> – выражение типа «дата».

<ИдентВида> – необязательный параметр. Строковое выражение, содержащее идентификатор вида документа или идентификатор Нумератора.

Возвращаемое значение: 1 – если действие выполнено и в выборке есть хотя бы один документ; 0 – если действие не выполнено или в выборке нет ни одного документа.

Пример:

Док = СоздатьОбъект("Документ");

// открываем выборку документов

Док.ВыбратьПоНомеру("Ав–0005", '01.01.98', "АктПереоценки");

// цикл получения документов

Пока Док.ПолучитьДокумент() > 0 Цикл

ТекДок = Док.ТекущийДокумент();

КонецЦикла;

ОбратныйПорядок(<Режим>) – устанавливает порядок выборки документов. Данный метод обычно используется до вызова одного из методов: ВыбратьДокументы(), ВыбратьПодчиненныеДокументы(), ВыбратьПоЗначению(), который фактически открывает выборку. Дальнейшая выборка при помощи ПолучитьДокумент() будет происходить в заданном порядке выборки. По умолчанию, выборка документов выполняется в порядке возрастания даты и времени записи документов. Поэтому реально имеет смысл применять данный метод только в том случае, если надо получить обратный порядок выборки. В тексте программного модуля возможно использование данного метода как процедуры или как функции. При использовании в качестве функции, возвращаемое значение соответствует текущему порядку выборки, которое было до вызова данного метода. Данный метод может использоваться только для объектов, созданных функцией СоздатьОбъект().

Параметры:

<Режим> – необязательный параметр. 1 – выбирать документы в обратном порядке даты и времени; 0 – выбирать документы в порядке возрастания даты и времени. Значение по умолчанию – 1.

Возвращаемое значение: текущее значение порядка выборки документов (на момент до исполнения метода): 1 – обратный порядок выборки документов; 0 – выборка документов в порядке возрастания даты и времени.

Пример:

Док = СоздатьОбъект("Документ");

// устанавливаем обратный порядок выборки документов

Док = ОбратныйПорядок(1);

// открываем выборку документов

Док.ВыбратьДокументы(ДатаНачало, ДатаКонец);

// цикл получения документов

Пока Док.ПолучитьДокумент() > 0 Цикл

ТекДок = Док.ТекущийДокумент();

КонецЦикла;

УстановитьФильтр(<Проведенные>, <НеПроведенные>, <НеИмеющиеПризнаковУчета>, <Оперативные>, <Расчетные>, <Бухг>) – назначает фильтр выборки документов. Данный метод может использоваться только для документов, созданных функцией СоздатьОбъект().

Параметры:

<Проведенные> – 0 – не включать в выборку проведенные документы; 1 – включать.

<НеПроведенные> – 0 – не включать в выборку непроведенные документы; 1 – включать.

<НеИмеющиеПризнаковУчета> – 0 – не включать в выборку документы не имеющие признаков учета; 1 – включать.

<0перативные> – 0 – не включать в выборку оперативные документы; 1 – данный флаг не влияет на выборку; 2 – если оперативный документ, то включается в выборку.

<Расчетные> – 0 – не включать в выборку расчетные документы; 1 – данный флаг не влияет на выборку; 2 – если расчетный документ, то включается в выборку.

<Бухг> – 0 – не включать в выборку бухгалтерские документы; 1 – данный флаг не влияет на выборку; 2 – если бухгалтерский документ, то включается в выборку.

Примеры:

Док.УстановитьФильтр(1, 1, 1, 1, 1, 1) – в выборку включаются все документы;

Док.УстановитьФильтр(1, 0, 1, 1, 1, 1) – в выборку включаются все проведенные документы;

Док.УстановитьФильтр(1, 1, 0, 1, 0, 1) – в выборку включаются все документы, имеющие признак оперативный или бухгалтерский или оба, но не имеют признака расчетный;

Док.УстановитьФильтр(1, 1, 1, 2, 1, 2) – в выборку включаются все документы, имеющие признаки и оперативный и бухгалтерский и те, которые не имеют признаков учета;

Док.УстановитьФильтр(1, 1, 1, 2, 0, 2) – в выборку включаются все документы, имеющие признаки и оперативный и бухгалтерский, но не имеют признака расчета, и те, которые не имеют признаков учета;

Док.УстановитьФильтр(1, 0, 0, 0, 1, 0) – в выборку не включаются проведенные документы, если они неоперативные и небухгалтерские и имеют признаки учета, т. е. фактически только проведенные расчетные.

Новый() – инициализирует создание нового документа. Собственно запись нового документа в информационную базу происходит при вызове метода Записать(). После инициализации создания нового документа, как правило производится заполнение его реквизитов с последующим вызовом метода Записать(). Данный метод может использоваться только для объектов, созданных функцией СоздатьОбъект().

Записать() – выполняет запись в базу данных текущего нового или измененного документа.

Пример:

// данная Процедура создает документ с № 1

Процедура Оприходовать()

Док = СоздатьОбъект("Документ.Приказы");

// найдем документ с № 1

Док.НайтиПоНомеру("1", 0);

Если Док.Выбран() = 0 Тогда

// Если документа с № 1 не существует, то создадим его

Док.Новый();

Док.НомерДок = "1";

Док.ДатаДок='01.01.80';

// запишем новый документ на диск

Док.Записать();

КонецЕсли;

КонецПроцедуры

Удалить(<Режим>) – удаляет (или делает пометку на удаление) текущий документ. Данный метод разрешено применять только для тех документов, которые либо не проведены, либо они лежат за точкой ТА, т. е. предполагается, что предварительно интерактивно сдвинули ТА назад. Данный метод может использоваться только для объектов, созданных функцией СоздатьОбъект().

Параметры:

<Режим> – необязательный параметр. 1 – непосредственное удаление; 0 – пометка на удаление. Значение по умолчанию – 1.

Пример:

Док = СоздатьОбъект("Документ.Приказы");

Если Док.Выбрать("Найди документ") > 0 Тогда

Док.Удалить(1);

КонецЕсли;

НоваяСтрока() – добавляет новую строку с очередным порядковым номером в многострочную часть документа.

Пример:

Процедура ОбработкаПодбора(Выб, КонФормы)

Кол=0;

Если ВвестиЧисло(Кол, "Введите количество", 10, 0) = 1 Тогда

// добавим новую строку в спецификацию

НоваяСтрока();

АктивизироватьСтроку();

КонецЕсли;

КонецПроцедуры

СортироватьСтроки(<Колонки>) – позволяет сортировать многострочную часть документа по реквизитам.

Параметры:

<Колонки> – перечисленные через запятую реквизиты многострочной части документа, по которым следует сортировать. Знаки "+", "–", предшествующие названию реквизита указывают направление сортировки по реквизиту. Знак "*" – сортировать по внутреннему значению реквизита.

Пример:

Док = СоздатьОбъект("Документ.Приказы");

Если Док.Выбрать("Найди документ") > 0 Тогда

Док.СортироватьСтроки("+Сумма, –НДС");

КонецЕсли;

Провести(<Режим>, <3нач>) – запускает процедуру проведения документа. Возвращаемое значение можно использовать, например, в качестве условия принятия решения при завершении обработки транзакции. Данный метод нельзя использовать в теле предопределенной процедуры ОбработкаПроведения().

Параметры:

<Режим> – необязательный параметр. 0 – проводить документ без сдвига ТА; 1 – проводить непроведенный документ реальным временем (со сдвигом ТА); 2 – перепроводить проведенный документ реальным временем (со сдвигом ТА); 3 –проводить любой (непроведенный, проведенный) документ реальным временем (со сдвигом ТА). Значение по умолчанию – 0.Данный параметр устанавливает режим проведения документа после ТА. Этот метод относится к случаю проведения документа в пределах даты, в которой находится ТА. Дело в том, что при записи документа, документ кроме даты получает еще и время документа. В многопользовательском режиме часто возникает ситуация, когда в момент проведения документа, он уже оказывается не последним в потоке проводимых документов (провели документ с другого рабочего места), в этом случае система 1С:Предприятие дает на выбор два варианта проведения:· провести документ тем временем, каким он был записан, т. е. фактически задним временем (до ТА);·изменить время документа в рамках текущей даты, чтобы документ стал самым последним и проводился в потоке, т. е. в ТА.

<3нач> – необязательный параметр. Выражение произвольного типа. Значение данного параметра будет передано системой в качестве параметра при запуске предопределенной процедуры ОбработкаПроведения. Использовать данное значение можно, например, для того, чтобы в процедуре ОбработкаПроведения правильно отработать режим проведения, т. к. это программный, а не интерактивный и не групповой способ проведения. По умолчанию передается пустое значение.

Возвращаемое значение: 1 – проведение документа завершено успешно; 0 – проведение документа не выполнено.

СделатьНеПроведенным() – отменяет проведение документа. Данный метод нельзя использовать в теле предопределенной процедуры ОбработкаПроведения(). Данный метод может использоваться только для объектов, созданных функцией СоздатьОбъект().

Пример:

Док.СоздатьОбъект("Документ.Заказ");

Док.НайтиДокумент(Докум);

Док.СделатьНеПроведенным();

СравнитьТА() – сверяет дату и время документа с датой и временем Точки актуальности итогов, позволяя определить положение на оси времени момента записи документа по отношению к текущему положению ТА.

Возвращаемое значение: числовое значение:

1 (плюс единица) – если дата и время документа больше даты и времени Точки актуальности итогов.

0 – если дата и время документа равно дате и времени Точки актуальности итогов.

–1 (минус единица) – если дата и время документа меньше даты и времени Точки актуальности итогов.

–2 (минус два) в случае, если новый документ, который сравнивается с ТА, еще не записан, то есть он еще не имеет никакой позиции на оси времени.

Предопределенные методы форм документа (должны располагаться только в Модулях формы документа)

ВводНового(<ПризнКопирования>, <ОбъектКопирования>) – вызов процедуры ВводНового производится в системе 1С:Предприятие неявно в момент создания нового документа. Данная процедура может использоваться, например, для установки начальных значений (по умолчанию) реквизитов нового документа. Если в данной предопределенной процедуре установить статус возврата – 0 (например, если данному пользователю нельзя вводить документы), ввода нового документа и открытие его формы не будет выполнено.

Параметры:

<ПризнКопирования> – признак того, что объект введен копированием. Число: 1 – объект введен копированием, 0 – просто новый объект. Данный признак может быть использован для анализа необходимости инициализации реквизитов нового объекта.

<ОбъектКопирования> – объект, который был скопирован.

Loading

Календарь

«  Июль 2019  »
ПнВтСрЧтПтСбВс
1234567
891011121314
15161718192021
22232425262728
293031

Архив записей

Друзья сайта

  • Заказать курсовую работу!
  • Выполнение любых чертежей
  • Новый фриланс 24