Центральный Дом Знаний - Работа в 1С 32

Информационный центр "Центральный Дом Знаний"

Заказать учебную работу! Жми!



ЖМИ: ТУТ ТЫСЯЧИ КУРСОВЫХ РАБОТ ДЛЯ ТЕБЯ

      cendomzn@yandex.ru  

Наш опрос

Как Вы планируете отдохнуть летом?
Всего ответов: 903

Онлайн всего: 3
Гостей: 3
Пользователей: 0


Форма входа

Логин:
Пароль:

Работа в 1С 32

Работа в программе 1С

стр.: 1  2  3  4  5  6  7  8  9  10  11  12  13  14  15  16  17  18  19  20  21  22  23  24  25  26  27  28  29  30  31  32
33  34  35  36  37  38  39  40  41  42  43  44  45  

Параметры:

<Измерен1>, <Измерен2>... – выражения со значениями измерений регистра.

Пример:

ДвижСотр= СоздатьОбъект("Регистр.ПриемСотрудников");

// Долж, Подр – переменные содержащие должность и подразделение,

// по которым необходимо получить количество

ДвижСотр.Итоги(Долж, Подр);

Кол = ДвижСотр.Количество;

СумОкл= ДвижСотр.СуммаОклада;

СводныйИтог(<Измерен1>, <Измерен2>..., <ИмяРесурса>) – возвращает сводный итог ресурса <ИмяРесурса> оборотного регистра. Данный метод работает аналогично методу Итог(), однако здесь могут быть заданы не все значения измерений, а только несколько, но обязательно в правильной последовательности, соответствующей структуре измерений данного регистра, как она задана в конфигураторе. Измерения могут задаваться с пропусками (неуказанное значение – просто запятая), фиксируются только указанные измерения. Данный метод используется только для оборотного регистра.

Параметры:

<Измерен1>, <Измерен2>... – выражения со значениями измерений регистра.

<ИмяРесурса> – строковое выражение, содержащее название требуемого ресурса регистра, как оно названо в конфигураторе.

Возвращаемое значение: численное значение сводного итога заданного ресурса регистра.

Пример:

ДвижСотр= СоздатьОбъект("Регистр.ПриемСотрудников");

// Долж, Подр – переменные содержащие должность и подразделение,

// по которым необходимо получить количество

Кол = ДвижСотр.СводныйИтог(Долж, Подр, "Количество");

Кол1 = ДвижСотр.СводныйИтог(, Подр, "Количество");

СводныеИтоги(<Измерен1>, <Измерен2>...) – извлекает по переданным в качестве параметров измерениям сводные итоги всех ресурсов оборотного регистра. Полученные ресурсы затем можно считывать из атрибутов регистра. Метод работает аналогично процедуре Итоги(), однако здесь могут быть заданы не все значения измерений, а только несколько, но обязательно в правильной последовательности, соответствующей структуре измерений данного регистра, как она задана в конфигураторе. Измерения могут задаваться с пропусками (неуказанное значение –просто запятая), фиксируются только указанные измерения. Данный метод используется только для оборотного регистра.

Параметры:

<Измерен1>, <Измерен2>... – выражения со значениями измерений регистра.

Пример:

ДвижСотр= СоздатьОбъект("Регистр.ПриемСотрудников");

// Долж, Подр – переменные содержащие должность и подразделение,

// по которым необходимо получить количество

ДвижСотр.СводныйИтоги(, Подр);

Кол = ДвижСотр.Количество;

ИтогиПолучить() – извлекает все итоги ресурсов оборотного регистра по измерениям, содержащимся в атрибутах. Полученные ресурсы затем можно считывать из атрибутов регистра. Данный метод используется только для оборотного регистра.

Пример:

ДвижСотр= СоздатьОбъект("Регистр.ПриемСотрудников");

// Долж, Подр – переменные содержащие должность и подразделение,

// по которым необходимо получить итоги

ДвижСотр.Должность = Долж;

ДвижСотр.Подразделение = Подр;

ДвижСотр.ИтогиПолучить();

Кол = ДвижСотр.Количество;

СумОкл= ДвижСотр.СуммаОклада;

Методы регистров остатков

Остаток(<Измерен1>, <Измерен2>..., <ИмяРесурса>) – возвращает остаток ресурса <ИмяРесурса> по регистру. Данный метод используется только для регистров остатков.

Параметры:

<Измерен1>, <Измерен2>... – выражения со значениями измерений регистра.

<ИмяРесурса> – строковое выражение, содержащее название требуемого ресурса регистра, как оно задано в конфигураторе.

Возвращаемое значение: численное значение остатка заданного ресурса регистра.

Пример:

Кол = Регистр.НаличиеСотрудников.Остаток(Долж, Подр, "Количество");

СумОкл = Регистр.НаличиеСотрудников.Остаток(Долж, Подр, "СуммаОклада");

СводныйОстаток(<Измерен1>, <Измерен2>..., <ИмяРесурса>) – возвращает сводный остаток ресурса <ИмяРесурса> по регистру. Данный метод работает аналогично методу Остаток(), однако здесь могут быть заданы не все значения измерений, а только несколько, но обязательно в правильной последовательности, соответствующей структуре измерений данного регистра, как она задана в конфигураторе. Измерения могут задаваться с пропусками (неуказанное значение – просто запятая), фиксируются только указанные измерения. Данный метод используется только для регистров остатков.

Параметры:

<Измepeн1>, <Измepeн2>... – выражения со значениями измерений регистра.

<ИмяРесурса> – строковое выражение, содержащее название требуемого ресурса регистра, как оно названо в конфигураторе.

Возвращаемое значение: численное значение сводного остатка заданного ресурса регистра.

Пример:

ОстКол = Регистр.НаличиеСотрудников.СводныйОстаток(, Подр, "Количество");

Остатки(<Измерен1>, <Измерен2>...) – извлекает по переданным в качестве параметров измерениям все ресурсы по регистру. Полученные ресурсы затем можно считывать из атрибутов регистра. Данный метод используется только для регистров остатков.

Параметры:

<Измерен1>, <Измерен2>... – выражения со значениями измерений регистра.

Пример:

Регистр.НаличиеСотрудников.Остатки(Долж, Подр);

ОстКол = Регистр.НаличиеСотрудников.Количество;

ОстСумОкл = Регистр.НаличиеСотрудников.СуммаОклада;

СводныеОстатки(<Измерен1>, <Измерен2>...) – извлекает по переданным в качестве параметров измерениям все ресурсы по регистру. Полученные ресурсы затем можно считывать из атрибутов регистра. Метод работает аналогично процедуре Остатки(), однако здесь могут быть заданы не все значения измерений, а только несколько, но обязательно в правильной последовательности, соответствующей структуре измерений данного регистра, как она задана в конфигураторе. Измерения могут задаваться с пропусками (неуказанное значение – просто запятая), фиксируются только указанные измерения. Данный метод используется только для регистров остатков.

Параметры:

<Измерен1>, <Измерен2>... – выражения со значениями измерений регистра.

Пример:

Регистр.НаличиеСотрудников.СводныеОстатки(Долж, );

ОстКол = Регистр.НаличиеСотрудников.Количество;

Регистр.НаличиеСотрудников.СводныеОстатки(, Подр);

ОстСумОкл = Регистр.НаличиеСотрудников.СуммаОклада

ОстаткиПолучить() – извлекает все ресурсы регистра по измерениям содержащимся в атрибутах. Полученные ресурсы затем можно считывать из атрибутов регистра. Данный метод используется только для регистров остатков.

Пример:

Регистр.НаличиеСотрудников.Должность = Долж;

Регистр.НаличиеСотрудников.Подразделение = Подр;

Регистр.НаличиеСотрудников.ОстаткиПолучить();

Сообщить("Наличие сотрудников данной должности =" + Строка(Регистр.НаличиеСотрудников.Количество));

ВыбратьДвиженияСОстатками(<КонецВыборки>, <ГрафаОтбора>) – инициирует выбор всех движении регистра в указанном интервале дат. До вызова данной процедуры может быть установлен фильтр, ограничивающий выборку значений из регистра. Если <КонецВыборки> не указан или равен 0, то конном временного интервала выбора движений регистра считается ТА.

Данный метод отличается от метода ВыбратьДвижения() тем, что после получения очередного движения метод Остаток() будет выдавать актуальные значения остатков для этого регистра. Но для этого перед вызовом метода ВыбратьДвиженияСОстатками() регистру должен быть установлен признак ВременногоРасчета и должен быть выполнен временный расчет – его дата и будет являться начальной датой выбираемых движений регистра. Данная возможность не может быть использована совместно с дальнейшими Временными расчетами.

Собственно выбор первого и последующих движений регистра осуществляется методом ПолучитьДвижение().

Параметры:

<КонецВыборки> – выражение типа дата, документ или позиция документа задающее конец временного интервала выбора движений регистра.

<ГрафаОтбора> – необязательный параметр. Строковое выражение – идентификатор графы отбора, как он задан в конфигураторе. Данный параметр устанавливает режим использования определенной графы отбора. "*" – автоматический выбор графы отбора. Пустая строка – не использовать графу отбора. По умолчанию устанавливается автоматический выбор графы отбора.

ВременныйРасчет(<Флаг>) – устанавливает флаг участия регистра во временном расчете. После такой установки можно выполнять процедуры РассчитатьРегистрыНа() и РассчитатьРегистрыПо(), тогда у данного регистра методы обращения к остаткам будут выдавать рассчитанные значения остатков на заданный момент времени. В один момент времени только по одному объекту регистров каждого вида могут участвовать во временном расчете.

Параметры:

<Флаг> – необязательный параметр. 1 – установить флаг участия регистра во временном расчете; 0 – сбросить флаг участия регистра во временном расчете. Значение по умолчанию – 1.

Возвращаемое значение: текущее числовое значение флага участия регистра во временном расчете.

РассчитатьРегистрыНа(<ГраницаРасчета>, <ГрафаОтбора>) – рассчитывает все регистры, у которых установлен флаг участия во временном расчете, на момент начала события. Если при вызове метода в параметре передана дата, то расчет временных регистров производится на начало указанной даты. Если при вызове метода в параметре передан документ, то расчет временных регистров производится на момент до проведения данного документа. Применение данной процедур в тексте любого программного модуля непосредственное, т. е. просто имя процедуры с параметрами (без предварительной ссылки на объект).

Параметры:

<ГраницаРасчета> – выражение со значением типа дата, документ или позиция документа.

<ГpaфaOтбopa> – необязательный параметр. Строковое выражение – идентификатор графы отбора, как он задан в конфигураторе. Данный параметр устанавливает режим использования определенной графы отбора. "*" – автоматический выбор графы отбора. Пустая строка – не использовать графу отбора. По умолчанию устанавливается автоматический выбор графы отбора.

Пример:

// Если итоги не актуальны, то стоимости берем из временного расчета

// регистра

Рег = СоздатьОбъект("Регистр.НаличиеСотрудников ");

Рег.ВременныйРасчет();

РассчитатьРегистрыНа(ТекущийДокумент());

Рег.Должность = Долж;

Рег.Подразделение = Подр;

Рег.ОстаткиПолучить();

ТекОстатокКол = Рег.Количество;

ТекОстСумОкл = Рег.СуммаОклада;

РассчитатьРегистрыПо(<ГраницаРасчета>, <ГрафаОтбора>) – рассчитывает все регистры, у которых установлен флаг участия во временном расчете, на момент окончания события. Если при вызове метода в параметре передана дата, то расчет временных регистров производится на конец указанной даты. Если при вызове метода в параметре передан документ, то расчет временных регистров производится на момент после проведения данного документа. Применение данной процедуры в тексте любого программного модуля непосредственное, т. е. просто имя процедуры с параметрами (без предварительной ссылки на объект).

Параметры:

<ГраницаРасчета> – выражение со значением типа дата, документ или позиция документа.

<ГрафаОтбора> – необязательный параметр. Строковое выражение – идентификатор графы отбора, как он задан в конфигураторе. Данный параметр устанавливает режим использования определенной графы отбора. "*" – автоматический выбор графы отбора. Пустая строка – не использовать графу отбора. По умолчанию устанавливается автоматический выбор графы отбора.

Пример:

// Если итоги не актуальны, то стоимости берем из временного расчета

// регистра

Рег = СоздатьОбъект("Регистр.НаличиеСотрудников ");

Рег.ВременныйРасчет();

РассчитатьРегистрыПо(ТекущийДокумент());

Рег.Должность = Долж;

Рег.Подразделение = Подр;

Рег.ОстаткиПолучить();

ТекОстатокКол = Рег.Количество;

ТекОстСумОкл = Рег.СуммаОклада;

УстановитьФильтр(<Измер1>, <Измер2>..., <Рекв1>, <Рекв2>, ...) – назначает фильтр для оптимизации действий с регистром (временные расчеты, выбор движений и итогов). В качестве фильтра задаются конкретные значения измерений и реквизитов регистра. Могут быть заданы не все значения, а только несколько, но обязательно в правильной последовательности, соответствующей структуре выбранного регистра, как она задана в конфигураторе. Измерения и реквизиты могут задаваться с пропусками (неуказанное значение – просто запятая), фиксируются только указанные значения.

Параметры:

<Измер1 >, <Измер2> – выражения со значениями измерений регистра.

<Рекв1>, <Рекв2> – необязательные параметры. Выражения со значениями реквизитов регистра. Заданные значения реквизитов будут влиять только на отбор движений регистра.

Пример:

Рег = СоздатьОбъект("Регистр.НаличиеСотрудников ");

Рег.ВременныйРасчет();

Рег.УстановитьФильтр(Долж, );

РассчитатьРегистрыНа(ДатаНачала);

Рег.ВыбратьДвиженияСОстатками(ДатаКонца);

Пока Рег.ПолучитьДвижение() = 1 Цикл

КонецЦикла;

УстановитьЗначениеФильтра(<ИзмерИлиРеквизит>, <3начен>, <Вариант>) – назначает фильтр для оптимизации расчетов. В качестве фильтра для измерения или реквизита регистра может задаваться либо конкретное значение, либо список значений либо группа для справочника.

Параметры:

<ИзмерИлиРеквизит> – идентификатор измерения или реквизита.

<3начен> – значение или список значений.

<Вариант> – необязательный параметр. Число: 0 – не фильтровать; 1 – фильтровать по значению; 2 – искать вхождение. Значение по умолчанию 1. Для варианта «2»:

  • если параметр <3начен> – это группа справочника, то осуществляется проверка вхождения в группу;

  • если параметр <3начен> – это простой элемент справочника или другой тип значения, то осуществляется просто фильтрация по значению;

  • для списка значений осуществляется проверка вхождения в список;

  • если пустое значение или пустой список значений, то условие не проверяется.

Пример:

Рег.УстановитьЗначениеФильтра("Подразделение", ВыбПодр, 2);

Следующие методы доступны только в контексте Модуля документа в системной предопределенной процедуре ОбработкаПроведения().

Перечисленные в этом разделе методы можно применять только к регистрам, непосредственно доступным в контексте Модуля документа, то есть нельзя создать объект типа Регистр с помощью функции СоздатьОбъект() и к нему применять метод из данного раздела.

ПривязыватьСтроку(<НомерСтроки>) – устанавливает, что при выполнении всех последующих движений регистров, движения будут записываться с номером строки <НомерСтроки>. Метод ПривязыватьСтроку() может быть использован как системная процедура: тогда он будет устанавливать номер строки для всех регистров по которым выполняются движения, или как метод конкретного регистра: тогда он будет устанавливать номер строки только для данного регистра. Данный метод доступен только в контексте Модуля документа в предопределенной процедуре ОбработкаПроведения().

Параметры:

<НомерСтроки> – выражение, содержащее номер строки документа

Пример:

Процедура ОбработкаПроведения()

Регистр.НаличиеСотрудников.Должность = Долж;

ВыбратьСтроки();

Пока (ПолучитьСтроку() > 0) Цикл

Регистр.НаличиеСотрудников.ПривязыватьСтроку(НомерСтроки);

Регистр.НаличиеСотрудников.Подразделение = Подр;

Регистр.НаличиеСотрудников.Количество = Количество;

Регистр.НаличиеСотрудников.СуммаОклада = СумОкл;

Регистр.НаличиеСотрудников.ДвижениеРасходВыполнить();

КонецЦикла;

КонецПроцедуры

ДвижениеПриход (<Измерен1>, <Измерен2> ... , <Ресурс1>, <Ресурс2> ...) – выполняет запись прихода в регистр для текущего документа. Измерения регистра, по которым записывается приход передаются параметрами <Измерение1>, <Измерение2>, ... Величина приращений приходуемых ресурсов регистра передаются параметрами <Ресурс1>, <Ресурс2>... Данный метод доступен только в контексте Модуля документа в предопределенной процедуре ОбработкаПроведения(). Данный метод используется только для регистров остатков

Параметры:

<Измерен1>, <Измерен2> – выражения со значениями измерений регистра.

<Ресурс1>, <Ресурс2> – выражения со значениями ресурсов регистра.

Пример:

Процедура ОбработкаПроведения();

ВыбратьСтроки();

Пока ПолучитьСтроку() > 0 Цикл

Регистр.НаличиеСотрудников.ПривязыватьСтроку(НомерСтроки);

Регистр.НаличиеСотрудников.ДвижениеПриход(Долж, Подр, Кол, СумОкл);

КонецЦикла;

КонецПроцедуры

ДвижениеРасход(<Измерен1>, <Измерен2>..., <Ресурс1>, <Ресурс2>...) выполняет запись расхода в регистр для текущего документа. Измерения регистра, по которым записывается расход передаются <Измерен1>, <Измерен2>, .. Величина приращений расходуемых ресурсов регистра передаются параметрами <Ресурс1>, <Ресурс2>... Данный метод доступен только в контексте Модуля документа в предопределенной процедуре ОбработкаПроведения(). Данный метод используется только для регистров остатков.

Параметры:

<Измерен1>, <Измерен2> – выражения со значениями измерений регистра.

<Ресурс1>, <Ресурс2> – выражения со значениями ресурсов регистра.

Пример:

Процедура ОбработкаПроведения();

ВыбратьСтроки();

Пока ПолучитьСтроку() > 0 Цикл

Регистр.НаличиеСотрудников.ПривязыватьСтроку(НомерСтроки);

Регистр.НаличиеСотрудников.ДвижениеРасход(Долж, Подр, Кол, СумОкл);

КонецЦикла;

КонецПроцедуры

ДвижениеПриходВыполнить() – выполняет запись прихода в регистр для текущего документа. Значения измерений регистра, по которым записывается приход, а также величины приращений приходуемых ресурсов регистра определяются текущими значениями атрибутов регистра. Данный метод доступен только в контексте Модуля документа в предопределенной процедуре ОбработкаПроведения(). Данный метод используется только для регистров остатков.

Пример:

Процедура ОбработкаПроведения()

ВыбратьСтроки();

Пока (ПолучитьСтроку() > 0) Цикл

Регистр.НаличиеСотрудников.Должность = Долж;

Регистр.НаличиеСотрудников.Подразделение = Подр;

Регистр.НаличиеСотрудников.Количество = Количество;

Регистр.НаличиеСотрудников.СуммаОклада = СумОкл;

Регистр.НаличиеСотрудников.ДвижениеПриходВыполнить();

КонецЦикла;

КонецПроцедуры

ДвижениеРасходВыполнить() – выполняет запись расхода в регистр для текущего документа. Значения измерений регистра, по которым записывается приход, а также величины приращений приходуемых ресурсов регистра определяются текущими значениями атрибутов регистра. Данный метод доступен только в контексте Модуле документа в предопределенной процедуре ОбработкаПроведения(). Данный метод используется только для регистров остатков.

Loading

Календарь

«  Май 2019  »
ПнВтСрЧтПтСбВс
  12345
6789101112
13141516171819
20212223242526
2728293031

Архив записей

Друзья сайта

  • Заказать курсовую работу!
  • Выполнение любых чертежей
  • Новый фриланс 24