Центральный Дом Знаний - Работа в 1С 27

Информационный центр "Центральный Дом Знаний"

Заказать учебную работу! Жми!



ЖМИ: ТУТ ТЫСЯЧИ КУРСОВЫХ РАБОТ ДЛЯ ТЕБЯ

      cendomzn@yandex.ru  

Наш опрос

Я учусь (закончил(-а) в
Всего ответов: 2653

Онлайн всего: 1
Гостей: 1
Пользователей: 0


Форма входа

Логин:
Пароль:

Работа в 1С 27

Работа в программе 1С

стр.: 1  2  3  4  5  6  7  8  9  10  11  12  13  14  15  16  17  18  19  20  21  22  23  24  25  26  27  28  29  30  31  32
33  34  35  36  37  38  39  40  41  42  43  44  45  

После выполнения метода Выполнить(), указатель становится на строку общих итогов. Затем в цикле проходим по значениям группировки Долж:

1 итерация цикла по Долж – позиционируемся на первое значение Бухгалтер и входим в цикл по группировке Сотр, проходим цикл по сотрудникам (Иванов, Петров) и после выхода из цикла по вложенной группировке Сотр возвращаемся на строку со значением внешней группировки Бухгалтер,

2 итерация цикла по Долж – позиционируемся на второе значение Программист и входим в цикл по группировке Сотр, проходим цикл по сотрудникам (Сидоров, Мусин, Васин) и после выхода из цикла по вложенной группировке Сотр возвращаемся на строку со значением внешней группировки Программист,

3 итерация цикла по Долж – позиционируемся на второе значение Рабочий и входим в цикл по группировке Сотр, проходим цикл по сотрудникам (Симонов, Ершов) и после выхода из цикла по вложенной группировке Сотр возвращаемся на строку со значением внешней группировки Рабочий,

указатель возвращается на строку общих итогов.

7.4 Сводные отчеты

Для получения сводной выходной информации в системе 1С:Предприятие используются объекты метаданных, называемые Отчет и Обработка. Объект данных этого типа представляет собой алгоритм обработки информации на внутреннем языке системы 1С:Предприятие. К алгоритму «прикрепляется» диалог, при помощи которого, при необходимости, можно организовать ввод каких–либо параметров, влияющих на ход его алгоритма. Обычно алгоритм имеет и сделанное в табличном редакторе описание печатной формы, которое используется для вывода результатов выполнения алгоритма на экран и принтер. В некоторых случаях одна и та же таблица используется и для ввода параметров, и для вывода результатов.

Название Отчеты и Обработка отражает два вида задач, которые могут выполняться объектами метаданных этих типов.

Во–первых, это получение разнообразных отчетных документов. В этом случае информация, накопленная в системе, используется для обобщения и формирования итоговых результатов в различных разрезах.

Во–вторых, это выполнение различных действий над информацией. Например, с их помощью можно выполнять удаление из системы устаревших данных, импорт информации из других систем и многое другое. Характер выполняемых в этом случае действий отражает название объекта метаданных – Обработка, так как в результате информация, хранящаяся в системе, претерпевает какие–либо изменения.

С точки зрения настройки, эти два типа объектов метаданных совершенно одинаковы. Однако рекомендуется алгоритмы, выполняющие какие–либо изменения в информационной базе, размещать на ветви Обработка и назначать права на использование обработок только наиболее подготовленным пользователям системы.

Далее в этой главе для простоты используется термин «отчет», при этом имеются в виду оба типа объектов метаданных.

Создадим отчет о сотрудниках, который мог бы выдать информацию в зависимости от введенных условий, например: об уволенных сотрудниках в разрезе дат увольнения или должностей, о работающих сотрудниках и т.д. Для этого создадим отчет. Найдите в дереве конфигурации тип Отчет и создайте новый отчет. На экране появится первое окно конструктора (рисунок 7.4.1), в котором укажем данные:

Рисунок 7.4.1

Нажмите кнопку Далее. Следующее окно позволяет автоматически вставить соответствующий пункт в меню (рисунок 7.4.2), но это можно сделать и позже вручную:

Рисунок 7.4.2

Следующее окно позволяет вызвать один из следующих конструкторов отчетов (рисунок 7.4.3). Если был выбран вызов конструктора, то при нажатии кнопки Готово, соответствующий конструктор начинает свою работу, иначе предоставляется возможность создать отчет самостоятельно. При необходимости конструкторы могут быть запущены и позже.

Рисунок 7.4.3

Не выбирая запуск конструкторов, нажмите кнопку Готово. В появившемся окне (рисунок 7.4.4) имеется экранная форма для установки параметров отчета, программный модуль для создания процедуры формирования отчета и таблица для определения внешнего вида отчета:

Рисунок 7.4.4

Разместите на экранной форме следующие элементы (рисунок 7.4.5):

Рисунок 7.4.5

Задайте для них следующие свойства:

  • для поля со списком (выпадающий список): Идентификатор – Статус, Формула – ВыборСтатуса();

  • для списка: Идентификатор – Группировка, опция Список с пометками установлена;

  • в группе переключателей Упорядочить по у первого переключателя ФИО: Идентификатор – Порядок, опция Первый в группе установлена (для остальных переключателей в группе свойства не устанавливаются);

  • в группе переключателей Выбрать у первого переключателя На дату: Идентификатор – ТипПериода, Формула – ВыборПериода(), опция Первый в группе установлена (для остальных переключателей в группе свойства не устанавливаются);

  • для поля ввода ВыбДата: Идентификатор – ВыбДата, Тип – Дата, опция Имеет кнопку выбора установлена;

  • для поля ввода ДатаНач: Идентификатор – ДатаНач, Тип – Дата, опции Сделать недоступным и Имеет кнопку выбора установлены;

  • для поля ввода ДатаКон: Идентификатор – ДатаКон, Тип – Дата, опции Сделать недоступным и Имеет кнопку выбора установлены.

Для корректной работы групп переключателей Упорядочить по и Выбрать необходимо установите правильный порядок обхода элементов на форме. Для этого в меню Диалог уберите флажок у пункта Автомат. порядок обхода (автоматически порядок обхода элементов на форме устанавливается в порядке их создания). Установить нужный порядок можно с помощью пункта Порядок обхода меню Диалог. После выбора этого пункта на форме перед каждым элементом появится квадратик с его номером обхода. Необходимо перенумеровать элементы слева на право и сверху вниз так, чтобы переключатели в группах имели соседние номера (рисунок 7.4.6). В этом случае при работе формы можно будет выбрать только один переключатель из группы.

Рисунок 7.4.6

Далее определим реакцию на выбор из списков, установку переключателей и ввод данных. Сейчас в программном модуле находится только заготовка процедуры Сформировать(). Создадим две переменные модуля ТипСтатуса и ТипГрупп, а в разделе основной программы модуля зададим начальные значения переменных и элементов диалога и значения элементов списков Статус и Группировка:

// эти переменные доступны в пределах всего модуля

Перем ТипСтатуса, ТипГрупп;

Процедура Сформировать()

КонецПроцедуры

// раздел основной программы модуля

// по умолчанию выбран первый элемент списка Статус

ТипСтатуса=1;

// по умолчанию группировки не отмечены

ТипГрупп=0;

// для группы переключателей Упорядочить по задаем, что активен

// первый переключатель ФИО

Порядок=1;

// для группы переключателей Выбрать задаем, что активен

// первый переключатель На дату

ТипПериода=1;

// добавляем элементы в список Статус (первый параметр – значение элемента,

// второй – его экранное представление)

Статус.ДобавитьЗначение(1,"Все работники");

Статус.ДобавитьЗначение(2,"Работающие");

Статус.ДобавитьЗначение(3,"Уволенные");

Статус.ДобавитьЗначение(4,"Принятые на работу");

// добавляем элементы в список Группировка (первый параметр – значение элемента,

// второй – его экранное представление)

Группировка.ДобавитьЗначение(1,"Группировать по должностям");

Группировка.ДобавитьЗначение(2,"Группировать по подразделениям");

// в поля ввода типа Дата ставим по умолчанию текущую дату

ВыбДата=ТекущаяДата();

ДатаНач=ТекущаяДата();

ДатаКон=ТекущаяДата();

В качестве формулы для элемента Статус была указана процедура ВыборСтатуса(), в которой при выборе элемента из списка Статус в переменную ТипСтатуса помещается значение выбранного элемента списка. Создадим такую процедуру после процедуру Сформировать(), но перед разделом основной программы модуля:

Процедура ВыборСтатуса()

ТипСтатуса=Статус.ПолучитьЗначение(Статус.ТекущаяСтрока());

КонецПроцедуры

В качестве формулы для элемента ТипПериода (первый переключатель в группе Выбрать) была указана процедура ВыборПериода(), которая должная работать следующим образом: если выбран переключатель На дату, то доступно поле ввода ВыбДата и недоступны поля ДатаНач и ДатаКон, если выбран переключатель За период – наоборот. Создадим такую процедуру:

Процедура ВыборПериода()

Если ТипПериода=1 Тогда

Форма.ВыбДата.Доступность(1);

Форма.ДатаНач.Доступность(0);

Форма.ДатаКон.Доступность(0);

Иначе

Форма.ВыбДата.Доступность(0);

Форма.ДатаНач.Доступность(1);

Форма.ДатаКон.Доступность(1);

КонецЕсли;

КонецПроцедуры

В данной процедуре через стандартный объект Форма (обозначающий текущую экранную форму) и имя (идентификатор) элемента диалога устанавливается свойство Доступность. Другие возможные действия с элементами диалога можно посмотреть в Синтаксис–Помощнике по ссылке Встроенный язык\Контекст формы\Объект «Форма»\Методы элементов диалога.

Сохраните конфигурацию и загрузите систему в режиме 1С: Предприятие. В меню Отчеты найдите пункт О сотрудниках и запустите его. Появившееся на экране окно (рисунок 7.4.7) позволяет настроить требуемый вид и содержание отчета: какие сотрудники попадут в отчет (все, уволенные, работающие и т.д.), как будет сгруппирована и отсортирована информация, за какой период или на какую дату будет создаваться отчет. Например, данный отчет должен выдать список всех сотрудников по подразделениям, отсортированный по ФИО.

Рисунок 7.4.7

Приступим к созданию макета отчета. С помощью Конструктора макета отчета или вручную создайте макет следующего вида с именем Сформировать (рисунок 7.4.8).

Рисунок 7.4.8

Теперь запрограммируем процедуру Сформировать(), где необходимо создать запрос в зависимости от введенных на экранной форме параметров и вывести отчет для просмотра. Как уже говорилось выше, текст запроса – это просто строка, содержащая команду на языке запросов. Поэтому данную строку можно создать постепенно, анализируя введенные параметры.

Loading

Календарь

«  Май 2019  »
ПнВтСрЧтПтСбВс
  12345
6789101112
13141516171819
20212223242526
2728293031

Архив записей

Друзья сайта

  • Заказать курсовую работу!
  • Выполнение любых чертежей
  • Новый фриланс 24