Центральный Дом Знаний - Работа в 1С 24

Информационный центр "Центральный Дом Знаний"

Заказать учебную работу! Жми!



ЖМИ: ТУТ ТЫСЯЧИ КУРСОВЫХ РАБОТ ДЛЯ ТЕБЯ

      cendomzn@yandex.ru  

Наш опрос

Как Вы планируете отдохнуть летом?
Всего ответов: 903

Онлайн всего: 1
Гостей: 1
Пользователей: 0


Форма входа

Логин:
Пароль:

Работа в 1С 24

Работа в программе 1С

стр.: 1  2  3  4  5  6  7  8  9  10  11  12  13  14  15  16  17  18  19  20  21  22  23  24  25  26  27  28  29  30  31  32
33  34  35  36  37  38  39  40  41  42  43  44  45  

<ИмяОпцийПечати> – необязательный параметр. Идентификатор набора опций печати для данной таблицы. Значение по умолчанию – пустая строка – в этом случае используются системные опции печати по умолчанию.

<ИмяСохрРазмОкна> – необязательный параметр. Строковое выражение – идентификатор сохраняемых параметров размеров окна. Если этот параметр указан, то система будет сохранять размер окна и использовать его при следующем открытии табличного документа. Фактически, указывая этот параметр, можно указать системе режим сохранения и восстановления размеров окна для данного табличного документа, который идентифицируется этой строкой. Параметр необязателен. Значение по умолчанию – пустая строка – в этом случае размеры окна не запоминаются.

<ФлагЧерноБелогоПросмотра> – необязательный параметр. 1 – черно–белый просмотр; 0 – обычный режим просмотра. Значение по умолчанию – 0.

<НаправлениеПерехода> – необязательный параметр. 1 – по строкам, т. е. при вводе данных в ячейки при нажатии клавиши Enter будет автоматически выполняться переход к следующей вводимой ячейке в этой строке, а если таковых нет, то в самой левой вводимой ячейке следующей строки; 2 – по столбцам, т. е. при вводе данных в ячейки при нажатии клавиши Enter будет автоматически выполняться переход к следующей вводимой ячейке в этом столбце, а если таковых нет, то в самой верхней вводимой ячейке следующего столбца; 3 – при вводе данных в ячейки автоматический переход при нажатии клавиши Enter выполняться не будет. Значение по умолчанию – 1.

Пример:

//Вызов выходного отчета в окно просмотра и редактирования.

Таб.ТолькоПросмотр(1);

Таб.Опции(0, 0, 5, 0, "ОстаткиТоваров");

Таб.Показать("Остатки товаров на складах", "");

ОбластьПечати(<Верх>, <Лево>, <Низ>, <Право>) – устанавливает область печати табличного документа

Параметры:

<Верх> – номер верхней строки таблицы, выводимой на печать.

<Лево> – номер крайнего левого столбца, выводимого на печать.

<Низ> – номер нижней строки таблицы, выводимой на печать.

<Право> – номер крайнего правого столбца, выводимого на печать.

Пример:

Таб.ОбластьПечати(1,2,10,4);

ПараметрыСтраницы(<Ориентация>, <Масштаб>, <РежимПечатиКопий>, <ПолеСлева>, <ПолеСправа>, <ПолеСверху>, <ПолеСнизу>, <КолонтитулСверху>, <КолонтитулСнизу>, <Автомасштаб> , <ФлагЧерноБелойПечати>, <ИмяПринтера>) – позволяет установить параметры страницы вывода на печать.

Параметры:

<Ориентация> – необязательный параметр. Ориентация вывода на печать: 1 – портрет; 2 – ландшафт.

<Масштаб> – необязательный параметр. Масштаб (в процентах) вывода на печать.

<РежимПечатиКопий> – необязательный параметр. Режим вывода нескольких копий на печать: 0 – (collate) выводить сначала первые страницы всех копий, затем вторые и т. д.; 1 – (разобрать) выводить страницы копий по порядку.

<ПолеСлева> – необязательный параметр. Расстояние (в миллиметрах) от правого края страницы.

<ПолеСверху> – необязательный параметр. Расстояние (в миллиметрах) от верхнего края страницы.

<ПолеСнизу> – необязательный параметр. Расстояние (в миллиметрах) от нижнего края страницы.

<КолонтитулСверху> – необязательный параметр. Размер (в миллиметрах) верхнего колонтитула.

<КолонтитулСнизу> – необязательный параметр. Размер (в миллиметрах) нижнего колонтитула.

<Автомасштаб> – необязательный параметр. Режим автоматического подбора масштаба для размещения документа при печати на листе по ширине. 1 – включить; 0 – выключить. По умолчанию – 0.

<ФлагЧерноБелойПечати> – необязательный параметр. 1 – черно–белая печать; 0 – обычный режим печати. Значение по умолчанию – 0.

<ИмяПринтера> – необязательный параметр. Строка как в стандартном диалоге печати.

Пример:

Таб.ПараметрыСтраницы(1, 100, 1, 17, 17, 25, 25, 10, 10);

КоличествоЭкземпляров(<Колич>) – позволяет установить количество печатаемых экземпляров. Если для текущей таблицы используется набор опций печати, то данный метод следует вызывать только после вызова метода Показать(), т. к. иначе будут действовать автоматически устанавливаемые настройки печати.

Параметры:

<Колич> – необязательный параметр. Количество печатаемых экземпляров.

Возвращаемое значение: текущее заданное количество печатаемых экземпляров (на момент до исполнения метода).

Пример:

Таб.КоличествоЭкземпляров(5);

ЭкземпляровНаСтранице(<Колич>) – позволяет установить количество печатаемых экземпляров на странице.

Параметры:

<Колич> – необязательный параметр. Количество печатаемых экземпляров на странице. Может принимать значения: 1 – один экземпляр на странице; 2 – два экземпляра на странице; 0 – автоматический режим размещения двух экземпляров на странице исходя из размеров документа.

Возвращаемое значение: текущее заданное количество печатаемых экземпляров на странице (на момент до исполнения метода).

Пример:

Таб.ЭкземпляровНаСтранице(2);

Напечатать{<Флаг>) – позволяет вывести таблицу на печать без открытия окна редактирования

Параметры:

<Флаг> – режим запроса диалога печати: 1 – запрашивать диалог печати; 0 – не запрашивать диалог печати.

Пример:

Таб.Напечатать(0);

К областям таблиц, то есть к ячейкам и диапазонам ячеек (напомним, что секция – это тоже диапазон ячеек), применимы следующие атрибуты и методы для установки параметров:

Пример:

Таб = СоздатьОбъект("Таблица");

Таб.Открыть("tabl_l.mxl");

ВыбОбласть = Таб.Область("R1C1");

// установить значение текста области

ВыбОбласть.Текст = "Товарный отчет";

// прочитать значение текста области

ЗнТекста = ВыбОбласть.Текст

ВыбОбласть = Таб.Область("R1C1:R8C4");

// Объединить ячейки области

ВыбОбласть.Объединить();

// установить шрифт области, где число – наборы символов: 204 – русский;

//238 – европейский; 186 – балтийский; 161 – греческий; 162 – турецкий

ВыбОбласть.Шрифт("Arial, 204");

// установить размер шрифта области 10

ВыбОбласть.РазмерШрифта(10);

// установить признак жирного шрифта области: 1 – жирный шрифт; 0 – не жирный

ВыбОбласть.Полужирный(1);

// установить признак шрифта курсив области: 1 – шрифт курсив; 0 – шрифт не курсив

ВыбОбласть.Курсив(1);

// установить признак подчеркнутого шрифта области: 1 – шрифт подчеркнутый;

// 0 – шрифт не подчеркнутый

ВыбОбласть.Подчеркнутый(1);

// установить признак вертикального выравнивания текста области: 1 – сверху; 2 – снизу;

// 3 – по центру

ВыбОбласть.ВертикальноеПоложение(3);

// установить признак горизонтального выравнивания текста области: 1 – слева;

// 2 – справа; 3 – по центру; 4 – по ширине,

// 5 – 8 – по выделенным столбцам: слева/справа/по центру/по ширине

ВыбОбласть.ГоризонтальноеПоложение(3);

// установить признак контроля текста области:: 1 – Авто; 2 – Обрезать; 3 – Забивать;

// 4 – Переносить; 5 – Красный; 6 – Забивать+Красный

ВыбОбласть.Контроль(4);

// установить рамку сверху области: 0 – нет; 1 – очень тонкая; 2 – тонкая точечная;

// 3 – тонкая сплошная; 4 – средняя сплошная; 5 – толстая сплошная; 6 – двойная;

// 7 – тонкая средний пунктир; 8 – тонкая длинный пунктир; 9 – толстая пунктир

ВыбОбласть.РамкаСверху(3);

// установить рамку снизу области (параметры те же)

ВыбОбласть.РамкаСнизу(3);

// установить рамку слева области (параметры те же)

ВыбОбласть.РамкаСлева(3);

// установить рамку справа области (параметры те же)

ВыбОбласть.РамкаСправа(3);

// Установить рамки всех ячеек области. Порядок – <РамкаСлева>, <РамкаСверху>,

// <РамкаСправа>, <РамкаСнизу>). Значения параметров те же.

ВыбОбласть.Рамка(0, 3, 3, 3);

// Установить рамки по краям области

ВыбОбласть.РамкаОбвести(0, 3, 3, 3);

// Параметры – числовые значения, красной, зеленой и синей компонент цвета от 0 до 256

ВыбОбласть.ЦветФона(34, 126, 211);

// установить режим отображения цвета рамки области

ВыбОбласть.ЦветРамки(34, 126, 211);

// установить режим отображения цвета текста области

ВыбОбласть.ЦветТекста(34, 126, 211);

// установить высоту строк, проходящих через область

ВыбОбласть.ВысотаСтроки(3);

// установить ширину столбцов, проходящих через область

ВыбОбласть.ШиринаСтолбца(13);

Предопределенные процедуры работы с таблицами:

ОбработкаЯчейкиТаблицы(<Значение>, <ФлагСтандартнойОбработки> , <КонтекстТаблицы>, <Адрес>) – вызов процедуры на исполнение производится в системе 1С:Предприятие по двойному щелчку мыши или по нажатию клавиши Enter в табличном документе на выбранной ячейке. Данная предопределенная процедура не вызывается при выборе ячейки таблицы в режиме ввода данных. Для этого случая вызывается предопределенная процедура ПриВыбореЯчейкиТаблицы().

Параметры:

<Значение> – в процедуру передается вычисленное значение ячейки.

<ФлагСтандартнойОбработки> – флаг, установка которого в теле процедуры в 1 приведет к выполнению стандартной обработки значения ячейки (открытию документа, элемента справочника и т. п.).

<КонтекстТаблицы> – необязательный параметр. Имя переменной, куда система передаст контекст всей таблицы. С помощью значения этого контекста можно произвольно манипулировать данной таблицей пока она открыта, например, вывести туда дополнительные секции или очистить и заполнить всю таблицу заново. Пока данный объект Таблица существует, тип значения данного параметра равен 100, если закрыта – 0.

<Адрес> – необязательный параметр. Имя переменной, куда система передаст адрес ячейки/объекта в формате «R1C1:R2C2».

ПриВыбореЯчейкиТаблицы(<ИмяИлиАдрес>, <Значение>) – вызов процедуры на исполнение производится в системе 1С:Предприятие по двойному щелчку мыши или по нажатию клавиши Enter на выбранной ячейке в таблице. Данная предопределенная процедура вызывается в модуле формы при выборе ячейки только для таблиц в режиме ввода данных

Параметры:

<ИмяИлиАдрес> – в процедуру системой передается строковое значение имени области таблицы, если выбранная ячейка помечена в таблице как отдельная область, или адрес ячейки в формате «R1C1:R2C2».

<Значение> – в процедуру системой передается значение данной ячейки, а если диаграмма – значение выбранного элемента.

Теперь рассмотрим более подробно процедуру

Процедура Печать()

// создаем таблицы

Таб = СоздатьОбъект("Таблица");

// в качестве исходной таблицы (макета) используем таблицу Печать

Таб.ИсходнаяТаблица("Печать");

// выводим секцию Шапка

Таб.ВывестиСекцию("Шапка");

// установка параметров показа таблицы

Таб.Опции(0,0,Таб.ВысотаТаблицы(),0);

// цикл, который должен выводить табличную часть

Пока <<Условие>> Цикл

Таб.ВывестиСекцию("Строка_1");

КонецЦикла;

// выводим подвал таблицы

Таб.ВывестиСекцию("Подвал");

// устанавливаем режим только просмотр

Таб.ТолькоПросмотр(1);

// показать таблицу

Таб.Показать("Приказ №","");

КонецПроцедуры

Цикл должен делать выборку по строкам документа (для нашего примера), элементам справочника и т. д. Дополним процедуру:

Процедура Печать()

Таб = СоздатьОбъект("Таблица");

Таб.ИсходнаяТаблица("Печать");

Таб.ВывестиСекцию("Шапка");

Таб.Опции(0,0,Таб.ВысотаТаблицы(),0);

// выборка строк документа

ВыбратьСтроки();

// пока строка выбрана

Пока ПолучитьСтроку()=1 Цикл

Таб.ВывестиСекцию("Строка_1");

КонецЦикла;

Таб.ВывестиСекцию("Подвал");

Таб.ТолькоПросмотр(1);

Таб.Показать("Приказ №","");

КонецПроцедуры

Сохраните Конфигурацию, запустите 1С в режиме Предприятие, создайте приказ о приеме двух или более человек, как основных, так и совместителей и нажмите кнопку Печать. На экране появится окно с таблицей (рисунок 7.2.1), построенной по макету (исходной таблице) Печать:

Рисунок 7.2.1

Поменяв имя исходной таблицы в процедуре Печать можно получить отчеты по макетам, отображенным на рисунках 7.1.8 и 7.1.9 (рисунки 7.2.2, 7.2.3).

Рисунок 7.2.2

Рисунок 7.2.3

Достаточно часто необходимо иметь возможность печати нескольких видов отчетов для одного объекта. В этом случае для каждого вида отчета можно конечно разместить на форме отдельную кнопку, но удобнее при нажатии кнопку Печать вызывать список доступных отчетов. В этом случае, если созданные макеты отчетов хранятся в отдельных таблицах (в нашем примере Печать, Печать1, Печать2), процедура Печать() измениться следующим образом:

Процедура Печать()

// создаем список типов отчетов

ТипОтчета=СоздатьОбъект("СписокЗначений");

// заполняем его даными

ТипОтчета.ИзСтрокиСРазделителями("""Таблица"", ""Сокращенная таблица"", ""Текст""");

// выбор из списка

ТипОтчета.ВыбратьЗначение(Выб,"",,,1);

Таб = СоздатьОбъект("Таблица");

// в зависимости от сделанного выбора в качестве исходной указывается

// соответствующая таблица

Если Выб="Таблица" Тогда

Таб.ИсходнаяТаблица("Печать");

ИначеЕсли Выб="Сокращенная таблица" Тогда

Таб.ИсходнаяТаблица("Печать1");

ИначеЕсли Выб="Текст" Тогда

Таб.ИсходнаяТаблица("Печать2");

КонецЕсли;

Таб.ВывестиСекцию("Шапка");

Таб.Опции(0,0,Таб.ВысотаТаблицы(),0);

ВыбратьСтроки();

Пока ПолучитьСтроку()=1 Цикл

Таб.ВывестиСекцию("Строка_1");

КонецЦикла;

Таб.ВывестиСекцию("Подвал");

Таб.ТолькоПросмотр(1);

Таб.Показать("Приказ №","");

КонецПроцедуры

Loading

Календарь

«  Июль 2019  »
ПнВтСрЧтПтСбВс
1234567
891011121314
15161718192021
22232425262728
293031

Архив записей

Друзья сайта

  • Заказать курсовую работу!
  • Выполнение любых чертежей
  • Новый фриланс 24