Центральный Дом Знаний - Работа в 1С 29

Информационный центр "Центральный Дом Знаний"

Заказать учебную работу! Жми!



ЖМИ: ТУТ ТЫСЯЧИ КУРСОВЫХ РАБОТ ДЛЯ ТЕБЯ

      cendomzn@yandex.ru  

Наш опрос

Я учусь (закончил(-а) в
Всего ответов: 2653

Онлайн всего: 1
Гостей: 1
Пользователей: 0


Форма входа

Логин:
Пароль:

Работа в 1С 29

Работа в программе 1С

стр.: 1  2  3  4  5  6  7  8  9  10  11  12  13  14  15  16  17  18  19  20  21  22  23  24  25  26  27  28  29  30  31  32
33  34  35  36  37  38  39  40  41  42  43  44  45  

// начальные значения

Год=ТекущаяДата();

Тип=1;

И соответствующий макет отчета Сформировать (рисунок 7.4.14):

Рисунок 7.4.14

После сохранения конфигурации и запуска системы в режиме Предприятие, вызовите отчет о доходах, как по отдельному сотруднику (рисунок 7.4.15), так и по всем (рисунок 7.4.16).

Рисунок 7.4.15

Рисунок 7.4.15

7.5 Обработки

Создадим обработку УдалениеУволенных, которая удалит всех уволенных работников, которые не присутствуют в документах Ведомость за указанный год. На экранную форму помещаем следующие элементы (рисунок 7.5.1):

Рисунок 7.5.1

В программном модуле запрограммируем процедуру Выполнить():

Процедура Выполнить()

Нач=НачГода(Год);

Кон=КонГода(Год);

//Создание объекта типа Запрос

Запрос = СоздатьОбъект("Запрос");

// данный запрос сделает выборку всех уволенных сотрудников,

// в справочнике Сотруднике и документах типа Ведомость

// группировка Документ является предопределенной

ТекстЗапроса =

"|Период с Нач По Кон;

|ОбрабатыватьДокументы Все;

|ФИО = Справочник.Сотрудники.ТекущийЭлемент, Документ.Ведомость.ФИО ;

|Группировка ФИО Упорядочить по ФИО.Наименование Без Групп;

|Группировка Документ;

|Функция Кол=Счётчик();

|Условие (Строка(ФИО.ДатаУвольнения)<>Строка(' . . '));

|";

// Если ошибка в запросе, то выход из процедуры

Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда

Возврат;

КонецЕсли;

Сотр=СоздатьОбъект("Справочник.Сотрудники");

// проходим по внешней группировке

Пока Запрос.Группировка(1) = 1 Цикл

// если сотрудник содержится в выборке только один раз,

// то есть только в справочнике

Если Запрос.Кол=1 Тогда

// встаем на соответствующий элемент в справочнике

Сотр.НайтиПоНаименованию(Запрос.ФИО.Наименование, 0, 1);

// если он найден

Если (Сотр.Выбран()=1) Тогда

// задаем вопрос

Если Вопрос("Удалить сотрудника " +Запрос.ФИО.Наименование+" ?",4)=6 Тогда

// удаляем элемент

Сотр.Удалить(1);

КонецЕсли;

КонецЕсли;

КонецЕсли;

КонецЦикла;

КонецПроцедуры


Год=ТекущаяДата();

Обработка автоматически не включается в меню, поэтому создайте самостоятельно новый пункт главного меню Обработка и подпункт Удаление уволенных, назначив ему в качестве команды открытие обработки УдалениеУволенных.

Сохраните конфигурацию и запустите 1С в режиме Предприятие. Через работу со справочником Сотрудники добавьте несколько сотрудников принятых на работу и уволенных в прошлом году. Запустите обработку, указав в качестве даты любую дату прошлого года. Те сотрудники, которые были только что введены, будут найдены (так они не присутствуют ни в какой ведомости) и выдан запрос на их удаление.

Задания:

В конфигурациях, созданных на прошлых занятиях, создайте указанные отчеты и обработки по вариантам:

Вариант 1

  • отчет для печати документа Приход и подведением итогов по суммам и количеству;

  • отчет для печати документа Продажа и подведением итогов по суммам и количеству;

  • сводный отчет по документам Приход за определенный период с возможностью группировки данных по художникам (как по ФИО художников, так и группам справочника Картины) и подведением итогов по суммам и количеству;

  • сводный отчет по документам Продажа за определенный период с возможностью группировки данных по художникам (как по ФИО художников, так и группам справочника Картины), году и подведением итогов по суммам и количеству;

  • сводный отчет по справочнику Картины с возможностью группировки и выборки данных по художникам (как по ФИО художников, так и группам справочника Картины), художественному стилю, годам создания и различными сортировками;

  • обработку удаления документов за определенный период.

Вариант 2

  • отчет для печати документа Приход и подведением итогов по суммам и количеству;

  • отчет для печати документа Продажа и подведением итогов по суммам и количеству;

  • сводный отчет по документам Приход за определенный период с возможностью группировки данных по товарам (как по названию товара, так и группам справочника Склад) и подведением итогов по суммам и количеству;

  • сводный отчет по документам Продажа за определенный период с возможностью группировки данных по товарам (как по названию товара, так и группам справочника Склад) и подведением итогов по суммам и количеству;

  • сводный отчет по справочнику Склад с возможностью группировки и выборки данных по товарам (как по названию товара, так и группам справочника Склад), типу товара, единицам измерения и различными сортировками;

  • обработку удаления документов за определенный период.

Вариант 3

  • отчет для печати документа Регистрация и подведением итогов по суммам и количеству;

  • отчет для печати документа Отказ и подведением итогов по суммам и количеству;

  • сводный отчет по документам Регистрация за определенный период с возможностью группировки данных по абонентам (как по названию ФИО абонента, так и группам справочника Абоненты) и подведением итогов по суммам и количеству;

  • сводный отчет по документам Отказ за определенный период с возможностью группировки данных по абонентам (как по названию ФИО абонента, так и группам справочника Абоненты) и подведением итогов по суммам и количеству;

  • сводный отчет по справочнику Абоненты с возможностью группировки и выборки данных по абонентам (как по названию ФИО абонента, так и группам справочника Абоненты), адресам, типу номера и различными сортировками;

  • обработку удаления документов за определенный период.

Вариант 4

  • отчет для печати документа Регистрация и подведением итогов по суммам и количеству;

  • отчет для печати документа Списание и подведением итогов по суммам и количеству;

  • сводный отчет по документам Регистрация за определенный период с возможностью группировки данных по книгам (как по названию книги, так и группам справочника Каталог) и подведением итогов по суммам и количеству;

  • сводный отчет по документам Списание за определенный период с возможностью группировки данных по книгам (как по названию книги, так и группам справочника Каталог) и подведением итогов по суммам и количеству;

  • сводный отчет по справочнику Каталог с возможностью группировки и выборки данных по книгам (как по названию книги, так и группам справочника Каталог), типу книги, издательству, году издания и различными сортировками;

  • обработку удаления документов за определенный период.

Вариант 5

  • отчет для печати документа ПостановкаНаУчет и подведением итогов по суммам и количеству;

  • отчет для печати документа СнятиеСУчета и подведением итогов по суммам и количеству;

  • сводный отчет по документам ПостановкаНаУчет за определенный период с возможностью группировки данных по налогоплательщикам (как по ФИО, так и группам справочника Налоги) и подведением итогов по суммам и количеству;

  • сводный отчет по документам СнятиеСУчета за определенный период с возможностью группировки данных по налогоплательщикам (как по ФИО, так и группам справочника Налоги) и подведением итогов по суммам и количеству;

  • сводный отчет по справочнику Налоги с возможностью группировки и выборки данных по налогоплательщикам (как по ФИО, так и группам справочника Налоги), типу льготы, адресу и различными сортировками;

  • обработку удаления документов за определенный период.

Вариант 6

  • отчет для печати документа ПостановкаНаУчет и подведением итогов по суммам и количеству;

  • отчет для печати документа СнятиеСУчета и подведением итогов по суммам и количеству;

  • сводный отчет по документам ПостановкаНаУчет за определенный период с возможностью группировки данных по соискателям (как по ФИО, так и группам справочника Соискатели) и подведением итогов по суммам и количеству;

  • сводный отчет по документам СнятиеСУчета за определенный период с возможностью группировки данных по соискателям (как по ФИО, так и группам справочника Соискатели) и подведением итогов по суммам и количеству;

  • сводный отчет по справочнику Соискатели с возможностью группировки и выборки данных по соискателям (как по ФИО, так и группам справочника Соискатели), профессии, типу образования и различными сортировками;

  • обработку удаления документов за определенный период.

Вариант 7

  • отчет для печати документа Регистрация и подведением итогов по суммам и количеству;

  • отчет для печати документа СнятиеСУчета и подведением итогов по суммам и количеству;

  • сводный отчет по документам Регистрация за определенный период с возможностью группировки данных по квартирам (как по ФИО владельца, так и группам справочника Квартиры) и подведением итогов по суммам и количеству;

  • сводный отчет по документам СнятиеСУчета за определенный период с возможностью группировки данных по квартирам (как по ФИО владельца, так и группам справочника Квартиры) и подведением итогов по суммам и количеству;

  • сводный отчет по справочнику Квартиры с возможностью группировки и выборки данных по квартирам (как по ФИО владельца, так и группам справочника Квартиры), типу квартиру, количеству комнат и различными сортировками;

  • обработку удаления документов за определенный период.

Вариант 8

  • отчет для печати документа Регистрация и подведением итогов по суммам и количеству;

  • отчет для печати документа ОсвобождениеНомера и подведением итогов по суммам и количеству;

  • сводный отчет по документам Регистрация за определенный период с возможностью группировки данных по типу номера (как по типу, так и группам справочника Номера) и подведением итогов по суммам и количеству;

  • сводный отчет по документам ОсвобождениеНомера за определенный период с возможностью группировки данных по типу номера (как по типу, так и группам справочника Номера) и подведением итогов по суммам и количеству;

  • сводный отчет по справочнику Номера с возможностью группировки и выборки данных по типу номера (как по типу, так и группам справочника Номера), количеству комнат, этажу, занятости и различными сортировками;

  • обработку удаления документов за определенный период.

Вариант 9

  • отчет для печати документа Подписка и подведением итогов по суммам и количеству;

  • отчет для печати документа ОтказОтПодписки и подведением итогов по суммам и количеству;

  • сводный отчет по документам Подписка за определенный период с возможностью группировки данных по типу издания (как по типу, так и группам справочника Подписка) и подведением итогов по суммам и количеству;

  • сводный отчет по документам ОтказОтПодписки за определенный период с возможностью группировки данных по типу издания (как по типу, так и группам справочника Подписка) и подведением итогов по суммам и количеству;

  • сводный отчет по справочнику Подписка с возможностью группировки и выборки данных по типу издания (как по типу, так и группам справочника Подписка), периодичности, сроку подписки и различными сортировками;

  • обработку удаления документов за определенный период.

Вариант 10

  • отчет для печати документа Прописка и подведением итогов по суммам и количеству;

  • отчет для печати документа Выписка и подведением итогов по суммам и количеству;

  • сводный отчет по документам Прописка за определенный период с возможностью группировки данных по ФИО (как по ФИО, так и группам справочника Квартиры) и подведением итогов по суммам и количеству;

  • сводный отчет по документам Выписка за определенный период с возможностью группировки данных по ФИО (как по ФИО, так и группам справочника Квартиры) и подведением итогов по суммам и количеству;

  • сводный отчет по справочнику Квартиры с возможностью группировки и выборки данных по ФИО (как по ФИО, так и группам справочника Квартиры), адресу, количеству комнат, типу квартиры и различными сортировками;

  • обработку удаления документов за определенный период.

Вариант 11

  • отчет для печати документа Продажа и подведением итогов по суммам и количеству;

  • отчет для печати документа Сдача и подведением итогов по суммам и количеству;

  • сводный отчет по документам Продажа за определенный период с возможностью группировки данных по направлениям (как по направлениям, так и группам справочника Касса) и подведением итогов по суммам и количеству;

  • сводный отчет по документам Сдача за определенный период с возможностью группировки данных по направлениям (как по направлениям, так и группам справочника Касса) и подведением итогов по суммам и количеству;

  • сводный отчет по справочнику Касса с возможностью группировки и выборки данных по направлениям (как по направлениям, так и группам справочника Касса), номеру вагона, времени, типу вагона и различными сортировками;

  • обработку удаления документов за определенный период.

Вариант 12

  • отчет для печати документа Продажа и подведением итогов по суммам и количеству;

  • отчет для печати документа Сдача и подведением итогов по суммам и количеству;

  • сводный отчет по документам Продажа за определенный период с возможностью группировки данных по городам (как по городам, так и группам справочника Путевки) и подведением итогов по суммам и количеству;

  • сводный отчет по документам Сдача за определенный период с возможностью группировки данных по городам (как по городам, так и группам справочника Путевки) и подведением итогов по суммам и количеству;

  • сводный отчет по справочнику Путевки с возможностью группировки и выборки данных по городам (как по городам, так и группам справочника Путевки), типу размещения, длительности и различными сортировками;

  • обработку удаления документов за определенный период.

Вариант 13

  • отчет для печати документа ПриемТовара и подведением итогов по суммам и количеству;

  • отчет для печати документа ПродажаТовара и подведением итогов по суммам и количеству;

  • сводный отчет по документам ПриемТовара за определенный период с возможностью группировки данных по типу обуви (как по типам, так и группам справочника Обувь) и подведением итогов по суммам и количеству;

  • сводный отчет по документам ПродажаТовара за определенный период с возможностью группировки данных по типу обуви (как по типам, так и группам справочника Обувь) и подведением итогов по суммам и количеству;

  • сводный отчет по справочнику Обувь с возможностью группировки и выборки данных по типу обуви (как по типам, так и группам справочника Обувь), сезону, дате поступления и различными сортировками;

  • обработку удаления документов за определенный период.

Вариант 14

  • отчет для печати документа ПриемТовара и подведением итогов по суммам и количеству;

  • отчет для печати документа ПродажаТовара и подведением итогов по суммам и количеству;

  • сводный отчет по документам ПриемТовара за определенный период с возможностью группировки данных по типу изделия (как по типам, так и группам справочника Драгоценности) и подведением итогов по суммам и количеству;

  • сводный отчет по документам ПродажаТовара за определенный период с возможностью группировки данных по типу изделия (как по типам, так и группам справочника Драгоценности) и подведением итогов по суммам и количеству;

  • сводный отчет по справочнику Драгоценности с возможностью группировки и выборки данных по типу изделия (как по типам, так и группам справочника Драгоценности), материалу, пробе и различными сортировками;

  • обработку удаления документов за определенный период.

Вариант 15

  • отчет для печати документа ПриказОПриеме и подведением итогов по суммам и количеству;

  • отчет для печати документа ПриказОбОтчислении и подведением итогов по суммам и количеству;

  • сводный отчет по документам ПриказОПриеме за определенный период с возможностью группировки данных по студенту (как по студенту, так и группам справочника Студенты) и подведением итогов по суммам и количеству;

  • сводный отчет по документам ПриказОбОтчислении за определенный период с возможностью группировки данных по студенту (как по студенту, так и группам справочника Студенты) и подведением итогов по суммам и количеству;

  • сводный отчет по справочнику Студенты с возможностью группировки и выборки данных по студенту (как по студенту, так и группам справочника Студенты), учебной группе, году рождения, типу оплаты и различными сортировками;

  • обработку удаления документов за определенный период.

Контрольные вопросы:

  1. Для чего служит Отчет?

  2. В чем отличие Отчета и Обработки?

  3. Какой объект используется для создания макета отчета?

  4. Как пользоваться Конструктором макета отчета?

  5. Как пометь свойства ячейки таблицы Отчета?

  6. Какая информация может содержаться в ячейке отчета типа Текст?

  7. Какая информация может содержаться в ячейке отчета типа Выражение?

  8. Какая информация может содержаться в ячейке отчета типа Шаблон?

  9. Какая информация может содержаться в ячейке отчета типа Фикс. Шаблон?

  10. Как объединить ячейки в Секцию?

  11. Как задать формат ячейки?

  12. Можно ли программно настраивать таблицу Отчета?

  13. Для чего используются Запросы?

  14. Какова структура Запроса?

  15. Как установить интервал Запроса?

  16. Как создать переменные Запроса?

  17. Для чего используются группировки?

  18. Как задать функции Запроса?

  19. Как задать условия Запроса?

  20. Как происходит проход по выборке запроса с одной группировкой?

  21. Как происходит проход по выборке запроса с двумя группировкам?

Loading

Календарь

«  Май 2019  »
ПнВтСрЧтПтСбВс
  12345
6789101112
13141516171819
20212223242526
2728293031

Архив записей

Друзья сайта

  • Заказать курсовую работу!
  • Выполнение любых чертежей
  • Новый фриланс 24